Splose runs completely from your browser. There are no apps necessary downloads required. we support many modern day web browsers and operating systems. Read on to learn about the technical requirements needed to run Splose.

Browser

Chrome: Version 66 or above

Firefox: Version 60 or above

Safari: Version 10.1 or above

Microsoft Edge: Version 41 or above

Unsupported browsers

If the browser you use isn't listed above, then we do not support it or guarantee the experience you may have using it. We don't fix bugs or issues for unsupported browsers, so we do our best to block them from accessing Splose.

Did this answer your question?